Jump to content
Mr. Stone

Pc problems

Recommended Posts

This problem been happing for a while. But its perma now. When i turn my pc on it starts up and I hear everything turn on but doesn't display nothing. The monitor i watch it turn on but displays a black screen anyone wanna help? I showed @vexer if he has anything to add, giver

Share this post


Link to post
Share on other sites

sounds like it isnt POSTing half the time, now it's not POSTing at all.

 

what motherboard do you have, does it show POST codes on it? Have you tried removing RAM sticks and trying 1 at a time? Have you ensured your monitor is plugged into your GPU and not onboard? Is there any fans spinning inside when you power on? 

Share this post


Link to post
Share on other sites

No, not to ensure your GPU is seated. I want you to ensure your monitor cables are plugged into your GPU, not your motherboard.

Share this post


Link to post
Share on other sites

Its very stupid but i fixed it... I did cable management to put all my wires behind and it come to find out it was shorting out.. Removed the back of the case starts up first try.. So if you having post problems check your wires or case for shortages

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×