Jump to content
Sign in to follow this  
Krystopher Malus †MAGA†

Player skins not loading?

Recommended Posts

On my main computer when I play this server I’ve noticed some of the player skins don’t load but instead render the models pitch black.  One of the skins is the alien brain zombie and the other is the little red riding hood anime girl, who’s clothing is rendered but skin is black.

 

I read somewhere that this could be because the files didn’t unpack correctly, but I’ve deleted all my CSGO files and reinstalled multiple times to try and fix this issue with no progress.  Does anyone know what I can try to fix this?

Share this post


Link to post
Share on other sites

So first of all, some players (Server officers and supporters) have the ability to use the command !glow which changes the player model color to the players desired color.

Second, instead of uninstalling your game and deleting your csgo files you can just validate your files through steam by going to library and right clicking on csgo, properties, local files, verify integrity of game files... (This usually works for me)

Lastly, its just two player models... it doesn't make the game unplayable to not see a few player models. 

 

 

drU0MI4.png

Share this post


Link to post
Share on other sites
1 hour ago, Guardian said:

So first of all, some players (Server officers and supporters) have the ability to use the command !glow which changes the player model color to the players desired color.

Second, instead of uninstalling your game and deleting your csgo files you can just validate your files through steam by going to library and right clicking on csgo, properties, local files, verify integrity of game files... (This usually works for me)

Lastly, its just two player models... it doesn't make the game unplayable to not see a few player models. 

 

 

drU0MI4.png

I have OCD and I’ve tried this as well with no luck.

Share this post


Link to post
Share on other sites

I'd assume that the reason you are getting black models is that the resources for the model failed to download but that the model downloaded fine (though I could very well be wrong). Try opening the model in the model viewer in Counter-Strike Global Offensive - SDK (you can download this by going to "Tools" part of your steam library) and see if it looks fine there. If it shows up as black in the model viewer, go to the materials tab at the bottom, select one of the materials on the left menu, then select $basetexture on the right menu. When you do this, you should see a file path like "models/player/some folder/model name/texture name" or something similar. Go to \Counter-Strike Global Offensive\csgo\materials\ on your computer (would be inside where you download your steam games), then navigate based on the file path that the model viewer gave you. If there is nothing there, it means you don't have the materials for the model downloaded. If there is something there, make sure it is named what the model viewer expects it to be named, as if the name is even 1 letter off, it won't be shown. Although these steps may not necessarily fix your problem, they might at least identify why you are getting the black models. If it shows up perfectly fine in the model viewer and the materials are where they are supposed to be, I have no idea why you are getting black custom models.

Share this post


Link to post
Share on other sites
1 hour ago, MistaChang said:

The issue is being looked into; it is server sided.
Thank you for reporting.

The skins load fine on my laptop when I tried, but if you can fix it to work on my main computer somehow that would be awesome.  I tried the model viewer and it appears some of the materials can’t be found.  Idk why it works on my laptop and not my desktop.

Edited by Krystopher Malus †MAGA†

Share this post


Link to post
Share on other sites
20 hours ago, Krystopher Malus †MAGA† said:

On my main computer when I play this server I’ve noticed some of the player skins don’t load but instead render the models pitch black.  One of the skins is the alien brain zombie and the other is the little red riding hood anime girl, who’s clothing is rendered but skin is black.

 

I read somewhere that this could be because the files didn’t unpack correctly, but I’ve deleted all my CSGO files and reinstalled multiple times to try and fix this issue with no progress.  Does anyone know what I can try to fix this?

Issue is solved. Make sure to thank @bulletford

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×