Jump to content
Sign in to follow this  
TheOrangeGrape

Rainbow Six Siege won't launch on this computer..

Recommended Posts

This isn't my computer but I currently can't even use mine soo yeah. I've already reinstalled several times but it still doesn't work, I've verified game cache, I've contacted steam support and they couldn't help. I've looked up on youtube and google and still no answers that could fix anything. Whenever I try to launch it, it just says I'm in game for 1-2 seconds then stops launching and just says I'm online. Anyone have any ideas? I've tried changing my compatibility settings and running as admin, still nothing.

 

edit: The specs on this computer should be even better than my computer so it should be able to run it. The first couple times I tried to run it it even worked. I didn't change anything in the files or anything but later on it just stopped working.

Edited by TheOrangeGrape

Share this post


Link to post
Share on other sites

Steam support walked me through that and I tried that also but it still didn't work. I'll try several things including this again now, though.

 

Edit: When I launch it through uplay a steam popup appears and it asks if it can run through steam and when I press accept (yes) it launches it through steam and the same problem occurs. How do I launch it through uplay but not through steam? @Zip

Edited by TheOrangeGrape

Share this post


Link to post
Share on other sites

Maybe a low amount of RAM and it wont start up?

Also maybe check your firewall programs, it may have falsely flagged one of the game files as unsafe and wont let it run.

Other than that idk.

Share this post


Link to post
Share on other sites
Just now, TheOrangeGrape said:

Steam support walked me through that and I tried that also but it still didn't work. I'll try several things including this again now, though.

 

Edit: When I launch it through uplay a steam popup appears and it asks if it can run through steam and when I press accept (yes) it launches it through steam and the same problem occurs. How do I launch it through uplay but not through steam? @Zip

Hm. That's weird. When I click on play on UPlay it just brings me into game doesn't ask me to go through steam.

Share this post


Link to post
Share on other sites
Just now, Zip said:

Hm. That's weird. When I click on play on UPlay it just brings me into game doesn't ask me to go through steam.

When I launch it on uplay is says this: "Do you want this app to make changes to your device? (steam client bootstrapper)"

Share this post


Link to post
Share on other sites
Just now, Taboo said:

https://steamcommunity.com/app/359550/discussions/0/359543951707157002/

you're probably missing a .dll


Sent from my iPhone using Tapatalk

I was so I downloaded it then I was missing another file, which I also downloaded so when I try to launch it now all it does is this, when I try to launch it directly this pops up: http://prntscr.com/fpcwoe but still nothing happens when I launch it through steam or uplay..

 

Edit: I ran a troubleshoot and this is what it ended up saying.. http://prntscr.com/fpd19g

Edited by TheOrangeGrape

Share this post


Link to post
Share on other sites
Just now, Taboo said:

http://www.tomshardware.com/answers/id-1991597/windows-bit-error-0xc000007b.html

its a pretty broad error that requires a ton of troubleshooting, try the solutions the best answer lists


Sent from my iPhone using Tapatalk

"Solution 1
In most cases it's .NET framework causing issues. This can easily fixed by re-installing latest .NET framework from"

how..?

Share this post


Link to post
Share on other sites

 
Edit: I also didn't install directX.


if you didnt have direct x installed the whole time then thats your problem lol


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Just now, Taboo said:

 


if you didnt have direct x installed the whole time then thats your problem lol


Sent from my iPhone using Tapatalk

 

Sorry, I have it but I havn't found how to uninstall/reinstall it yet, I'm looking now, though ;-;

 

(edit: I have directx 12, can't find where to uninstall/reinstall though)

Edited by TheOrangeGrape

Share this post


Link to post
Share on other sites
Just now, Taboo said:

okay but how do I uninstall it? I've seen several ways how but I havn't done anything, am I supposed to restore my computer..?

 

(edit) I installed it and it's asking me to type the location where I want to place the extracted files

Edited by TheOrangeGrape

Share this post


Link to post
Share on other sites

edit: i just saw your edit, just extract it anywhere in a new folder and it should have dxsetup.exe or dxwebsetup.exe in it
you can't uninstall directx, you use the installer i linked and if it passes with this:

 7zkv9g.png
and doesn't detect any errors then it's not your directx

 

also run dxdiag (search dxdiag in start menu if you're on win10) and check for errors

also make sure your gpu drivers are up to date
 

if directx is showing 0 problems then run https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

last resort would be to just clean install windows

Edited by Taboo

Share this post


Link to post
Share on other sites
3 hours ago, Taboo said:

edit: i just saw your edit, just extract it anywhere in a new folder and it should have dxsetup.exe or dxwebsetup.exe in it
you can't uninstall directx, you use the installer i linked and if it passes with this:

 7zkv9g.png
and doesn't detect any errors then it's not your directx

 

also run dxdiag (search dxdiag in start menu if you're on win10) and check for errors

also make sure your gpu drivers are up to date
 

if directx is showing 0 problems then run https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

last resort would be to just clean install windows

For this cmd console and the last one it won't work, for this one at the microsoft report this is what it says after I command it to say this "sfc /scannow" It says, "You must be an adminstrator running a console session in order to use the sfc utility. Though I thought I was an administrator..

Share this post


Link to post
Share on other sites
6 hours ago, TheOrangeGrape said:

For this cmd console and the last one it won't work, for this one at the microsoft report this is what it says after I command it to say this "sfc /scannow" It says, "You must be an adminstrator running a console session in order to use the sfc utility. Though I thought I was an administrator..

run command prompt as administrator. 

 

On windows 10, Right click the Start button in the bottom right, and click Command Prompt (Admin)

 

Also Taboo mentioned it but make sure your drivers are up to date. 

Share this post


Link to post
Share on other sites
34 minutes ago, nothing_but_fail said:

Also Taboo mentioned it but make sure your drivers are up to date.

I "checked for updates" if that's what you mean and updated everything?

Share this post


Link to post
Share on other sites
13 hours ago, Taboo said:

edit: i just saw your edit, just extract it anywhere in a new folder and it should have dxsetup.exe or dxwebsetup.exe in it
you can't uninstall directx, you use the installer i linked and if it passes with this:

 7zkv9g.png
and doesn't detect any errors then it's not your directx

 

also run dxdiag (search dxdiag in start menu if you're on win10) and check for errors

also make sure your gpu drivers are up to date
 

if directx is showing 0 problems then run https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

last resort would be to just clean install windows

I did everything, no errors, no integrity violations. so what next?

Share this post


Link to post
Share on other sites

if i can assume you did everything correctly and thoroughly, then i have no idea except for reinstalling windows


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
6 hours ago, Taboo said:

if i can assume you did everything correctly and thoroughly, then i have no idea except for reinstalling windows


Sent from my iPhone using Tapatalk

I did everything except clean installing windows.. sry for confusion

@Taboo how do i clean install or reinstall windows?

Edited by TheOrangeGrape

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×